ComX Computers - since 2002 • home Mon 9 Nov, 2026View enquiry cart
Computers, laptops and PC hardware in South Africa.Computers
Laptops
Laptops, computers and computer hardware South Africa Computers, laptops and other PC hardware in South Africa.
Computers South AfricaLaptops, Notebooks and PDA South AfricaDigital camerasComputer hardware Tablets South AfricaSoftware - software titles South AfricaPrinters South Africa SpeakersGaming Brands
PC
My account  |  How to buy  |  Specials
computer salespc salescomputerscomputerscomputers
computers
 
computers
computers

B-7300RA Billion B-7300RA ADSL 2+ Modem / Router

computers


Billion B-7300RA ADSL 2+ Modem / Router
Images are for illustrative purposes and actual product may differ.

   

B-7300RA

Network Routers (wired broadband routers)

Billion


B-7300RA information and overview
Billion B-7300RA ADSL 2+ Modem / Router, 4 Port Switch
Not for sale. This is a discontinued product.

Kindly search for an alternative on our site

Subject to correction, the product was first added on 2010-11-24 and the last date we have for this product is 2012-10-17, where the last unit was sold for R 401, which may have been a final clearance price.



Specifications & more information about B-7300RA, Network Routers (wired broadband routers) manufactured by Billion
Specifications & downloads View specification Printable PDF
Product information notice: Some specifications may describe a broader product range and may not apply to this exact model. Use the product summary above as the primary model reference. Bundled software may be trial software and can require a separate licence.

Overview:
Billion’s BiPAC 7300(G) RA series is an all-in-one compact package of ADSL2+ router perfectly designed for home and SOHO users to enjoy the mobility and faster speed when using ADSL Internet connection. The device lets you access high-speed ADSL Internet connection, even faster with advanced ADSL2+ capability with downstream rate up to 24 Mbps. The router supports Easy Sign-On (EZSO) technology, enabling users to establish ADSL connections via standard web browsers such as Internet Explorer. This user-friendly design supports all kinds of operating systems, significantly reducing the time and efforts spent configuring your system. An abundance of integrated firewall security features such as SPI, DoS attack prevention, and URL Content Filtering provide users unparalleled protection from hackers. The Quality of Service feature ensures a smooth net connection for inbound and outbound data, with minimal traffic
congestion.

Features:

  • High speed Internet access with ADSL2/2+; backward compatible with ADSL
  • 802.11g wireless AP with WPA-PSK/ WPA2-PSK support (BiPAC 7300G RA)
  • Auto channel select
  • SOHO firewall security with DoS prevention and packet filtering
  • Easy Sign-On (EZSO) and web-based configuration
  • Quality of Service control
  • Universal Plug and Play (UPnP) ompliant
  • Dynamic Domain Name System (DDNS)
  • Supports VPN pass-through
  • Ideal for home & SOHO users

Specifications:

© 2026 Respective owners and brand holders. This table has been carefully researched and generated by ComXpert International CC (//www.comx-computers.co.za), however, errors and omissions may occur. Only references to South Africa apply. All products are sourced in South Africa from the official suppliers and the warranty is that of the local supplier. E&OE. This table and our site's content may be used on condition that this notice and link remains intact and unaltered.
Specifications for the product series
Product Code B-7300RAspacer
ADSL Compliance Compliant with ADSL Standard
- Full-rate ANSI T1.413 Issue 2
- G.dmt (ITU G.992.1)
- G.lite (ITU G.992.2)
- G.hs (ITU G.994.1)
- ADSL over ISDN/U-R2
Compliant with ADSL2 Standard
- G.dmt.bis (ITU G.992.3)
- ADSL2 Annex M (ITU G.992.3 Annex M) (BiPAC 7300(G)RA A only)
Compliant with ADSL2+ Standard
- G.dmt.bisplus (ITU G.992.5)
- ADSL2+ Annex M (ITU G.992.5 Annex M) (BiPAC 7300(G) RA A only)
Network Protocols and Features NAT, static routing and RIP-1/2
NAT supports PAT and multimedia applications
Transparent Bridging
Virtual Server and DMZ
SNTP, DNS relay and DDNS
IGMP snooping and IGMP proxy
Firewall & Virtual Private Network (VPN) Built-in NAT Firewall
Stateful Packet Inspection (SPI)
Prevents DoS attacks including Land Attack, Ping of Death, etc.
Remote access control for web base access
Packet and URL filtering
Password protection for system management
VPN pass-through
Quality of Service Control Supports the DiffServ approach
Traffic prioritization based-on IP protocol, port number and address
Compliant with IEEE 802.11g and 802.11b standards
2.4 GHz – 2.484G Hz frequency range
Up to 54 Mbps wireless operation rate
Auto channel select
64/128 bits WEP supported for encryption
Wireless Security with WPA-PSK/WPA2-PSK support
WDS repeater function support
ATM and PPP Protocols ATM Adaptation Layer Type 5 (AAL5)
Multiple Protocol over AAL5 (RFC 2684, formerly RFC 1483)
Bridged or routed Ethernet encapsulation
VC and LLC based multiplexing
PPP over Ethernet (PPPoE)
PPP over ATM (RFC 2364)
OAM F4/F5
Management Quick Installation Wizard and Auto-scan ADSL settings
Web-based for remote and local management
Firmware upgrades and configuration data upload/download via web-based interface
Embedded Telnet server for local management
SNMP v1/v2/v3, MIB-I and MIB-II support
Available Syslog monitoring
Supports DHCP server/client/relay
Mail Alert
Operating Environment Operating temperature: 0 - 40ºC
Storage temperature: -20 - 70ºC
Humidity: 20 - 95% non-condensing
Hardware Specifications WLAN: 1 detachable antenna
LINE: ADSL port
LAN: 4-port 10/100M auto-crossover (MDI/MDI-X) switch
Factory default reset button
Power jack
Power switch
Power jack
Factory default reset button
LAN: 4-port 10/100M auto-crossover (MDI/MDI-X) switch
LINE: ADSL port
Physical Specifications BiPAC 7300G RA
Dimensions: 7.28" x 4.86" x 1.42" (185mm x 123.5mm x 35mm)
BiPAC 7300 RA
Dimensions: 5.51" x 3.54" x 1.38” (140.5mm*90.5mm*35mm)
Power Requirements Input: 12V DC, 1A
Models & Supported Standards BiPAC 7300(G) RA A: Annex A & Annex M (Annex A and Annex M: ADSL over POTS)
BiPAC 7300(G) RA U: Annex B & U-R2 (Annex B and Annex U-R2: ADSL over ISDN)


Reviews about B-7300RA Billion B-7300RA ADSL 2+ Modem / Router

There are no reviews about this product
+ Be the first to add a review


Reviews have been submitted by users and do not necessarily reflect our own opinion.

WebAfrica Internet



The best price and guaranteed service and backup from official computer suppliers in South Africa for the B-7300RA Billion B-7300RA ADSL 2+ Modem / Router.
Available from this online computer store delivering door-to-door in Johannesburg, Cape Town, Port Elizabeth, Pretoria, Pietermaritzburg, Polokwane, Durban and all over South Africa.

Find related B-7300RA Billion B-7300RA ADSL 2+ Modem / Router products in our Network Routers (wired broadband routers) Category for even more options. Read reviews and find out about B-7300RA Billion B-7300RA ADSL 2+ Modem / Router. Discounts, specials and cheap prices only at ComX Computers.




 
B-7300RA laptops South AfricaB-7300RA Notebooks South AfricacomputersB-7300RA notebook sales in South Africa
Home | Contact Us | Privacy Policy | Shop by Brand | Shop by Category
CGSO
ComX Computers is a South African online store since 2002. All transactions are subject to our terms of sale.