| |
TDM-C500 Trendnet ADSL Fast Ethernet/USB Combination Modem Router
Images are for illustrative purposes and actual product may differ.
TDM-C500 Network Routers (wired broadband routers)TRENDnet
TDM-C500 information and overview
Trendnet ADSL Fast Ethernet/USB Combination Modem Router
Not for sale. This is a discontinued product.
Kindly search for an alternative on our site
Subject to correction, the product was first added on 2011-09-02 and the last date we have for this product is 2014-01-28, where the last unit was sold for R 350, which may have been a final clearance price.
Specifications & more information about TDM-C500, Network Routers (wired broadband routers) manufactured by TRENDnet
Product information notice: Some specifications may describe a broader product range and may not apply to this exact model. Use the product summary above as the primary model reference. Bundled software may be trial software and can require a separate licence.
Overview: The ADSL 2/2+ Modem Router, model TDM-C500, provides a modem for Internet access and a high speed router to allow multiple connections to the internet. It supports all Internet service providers with ADSL 2, ADSL 2+, Annex A, Annex L, or Annex M networks. Installation is a breeze with a step-by-step setup wizard; status LEDs convey devices status; and a convenient on/off power button protects hardware when powering down. Protect your data with a dual NAT and SPI firewall. Manage access to the Internet with IP port and MAC address filtering and URL and domain name blocking controls. Additional features include a browser-based management interface, SNMP v1 and v2 support, QoS data prioritization, DMZ controls, Port Forwarding, and Dynamic DNS support. Features: - 1 x 10/100Mbps Auto-MDIX RJ-45 port
- 1 x RJ-11 port
- 1 x USB 2.0 Type B-port (male) for alternate Ethernet connection
- On / off power button
- Diagnostic LEDs
Modem features: - Compliant with ADSL, ADSL2, and ADSL2+ (Annex A, L, and M) standards
- Up to 24Mbps downstream and 1.2Mbps upstream Annex M is up to 3Mbps upstream
- Compliant with PPPoE, PPPoA, and IPoA connection types
Router features: - Supports up to 8 PVCs
- Compliant with SNMP v1 and v2c standards and Supports IGMP v1 and v2, port forwarding, and DMZ controls
- Supports RIP, Static routing, and Dynamic DNS service
- Advanced Firewall protection with Network Address Translation (NAT) and Stateful Packet Inspection (SPI)
- Internet Access Control (MAC Address, Domain, URL, and IP Filtering) support
- Supports IP Quality of Service (QoS)
- Easy configuration and remote management with a Web browser (HTTP), and CLI
- Universal Plug and Play (UPnP) and Application Level Gateway support for Internet applications such as email, FTP, gaming, remote desktop, Net Meeting, telnet and more
Specifications: | © 2026 Respective owners and brand holders. This table has been carefully researched and generated by ComXpert International CC (//www.comx-computers.co.za), however, errors and omissions may occur. Only references to South Africa apply. All products are sourced in South Africa from the official suppliers and the warranty is that of the local supplier. E&OE. This table and our site's content may be used on condition that this notice and link remains intact and unaltered. | Specifications for the product series | | Product Code | TDM-C500 | | Hardware | | Standards | Compliant with ADSL standards | | - ANSI T1.413 Issue2 | | - G.992.1 (G.dmt, Annex A) | | - G.992.2 (G.lite) | | Compliant with ADSL2 standard | | - G.992.3 (G.dmt.bis, Annex L) | | Compliant with ADSL2+ standard | | - G.992.5 Annex A and M | | IEEE 802.3u 10/100Base TX Fast Ethernet | | Protocol | TCP/IP, NAT, HTTP, DHCP Server/Relay/Client, DDNS, DNS Proxy, UPNP | | Firewall | Network Address Translation (NAT) | | Stateful Packet Inspection (SPI) | | Packet Filtering – IP, MAC, Domain, Keyword | | Management Access Control for LAN | | ATM | VC and LLC Multiplexing | | Bridged/Routed Ethernet over ATM (RFC1483/2684) | | OAM F4/F5 loop-back | | PPP over ATM (RFC2364) | | PPP over Ethernet (RFC2516) | | ATM Traffic Shaping QoS(UBR, CBR, rt-VBR, nrt-VBR) | | Management | Web based Configuration (HTTP) | | Command Line Interface (CLI) via Telnet | | SNMP v1 and v2c | | IGMP v1 and v2 | | SW upgrade | | WAN Port (ADSL line Interface) | 1 x RJ-11 port | | LAN Port | 1 x 10/100Mbps Auto-MDIX RJ-45 port | | USB | Type B male port, supporting USB 2.0 and backwards compatible with 1.0 (optional LAN port) | | Reset Button | Reset to factory default | | On/Off Power Button | Power on/off button | | LED | Power, LAN: Link/ACT, USB, ADSL, Internet, USB | | Power | A: 9V, 1A external power adapter | | EU : 9V, 0.5A external power adapter | | Power Consumption | 4.3 Watts | | Dimensions | 90 x 107 x 28 mm (3.5 x 4.2 x 1.1 in) | | Weight | 221 g (7.8 oz) | | Temperature | Operating: 0˚~ 40˚C (32˚~ 104˚F) | | Storage: -10˚~ 70˚C (-14˚~ 158˚F) | | Humidity | Max. 90% (non-condensation) | | Certifications | CE, FCC |
Similar Network Routers (wired broadband routers)
The best price and guaranteed service and backup from official computer suppliers in South Africa for the TDM-C500 Trendnet ADSL Fast Ethernet/USB Combination Modem Router. Available from this online computer store delivering door-to-door in Johannesburg, Cape Town, Port Elizabeth, Pretoria, Pietermaritzburg, Polokwane, Durban and all over South Africa. Find related TDM-C500 Trendnet ADSL Fast Ethernet/USB Combination Modem Router products in our Network Routers (wired broadband routers) Category for even more options. Read reviews and find out about TDM-C500 Trendnet ADSL Fast Ethernet/USB Combination Modem Router. Discounts, specials and cheap prices only at ComX Computers.
| |