| |
TDM-C504 Trendnet ADSL Fast Ethernet/USB Combo Modem/Router
Images are for illustrative purposes and actual product may differ.
TDM-C504 Network Routers (wired broadband routers)TRENDnet
TDM-C504 information and overview
Trendnet ADSL Fast Ethernet/USB Combo Modem/Router - 4 P/Sw
Not for sale. This is a discontinued product.
Kindly search for an alternative on our site
Subject to correction, the product was first added on 2011-09-02 and the last date we have for this product is 2014-01-28, where the last unit was sold for R 442, which may have been a final clearance price.
Specifications & more information about TDM-C504, Network Routers (wired broadband routers) manufactured by TRENDnet
Product information notice: Some specifications may describe a broader product range and may not apply to this exact model. Use the product summary above as the primary model reference. Bundled software may be trial software and can require a separate licence.
Overview: The 4-Port ADSL 2/2+ Modem Router, model TDM-C504, provides a modem for Internet access, a router for multiple Internet connections, and a 4-port switch to network computers and other devices. This combination modem router supports Internet service providers with ADSL 2 and ADSL 2+ networks. Installation is a breeze with a step-by-step setup wizard. LEDs convey devices status and a convenient on/off power button protects hardware when powering down. A firewall protects your valuable data. Manage access to the Internet with Port and MAC address filtering and URL and domain name blocking. Additional features include a browser-based management interface, SNMP v1 and v2c support, QoS data prioritization, DMZ controls, Port Forwarding, and DDNS support. Features: - 4 x 10/100Mbps Auto-MDIX RJ-45 port
- 1 x RJ-11 port
- On / off power button
- Diagnostic LEDs
Modem features: - Compliant with ADSL, ADSL2, and ADSL2+ (Annex A, L, and M) standards
- Up to 24Mbps/1Mbps data rate downstream/upstream
- Compliant with PPPoE, PPPoA, and IPoA connection types
- Supports up to 8 PVCs
Router features: - Compliant with SNMP v2c standards and Supports IGMP v1 and v2, port forwarding, and DMZ controls
- Supports RIP (v1 and v2), Static routing, and Dynamic DNS service
- Advanced Firewall protection with Network Address Translation (NAT) and Stateful Packet Inspection (SPI)
- Internet Access Control (MAC Address, Domain, URL, and IP Filtering) support
- Supports IP Quality of Service (QoS)
- Easy configuration and remote management with a Web browser (HTTP) and CLI
- Universal Plug and Play (UPnP)
- Application Level Gateway support for Internet applications such as email, FTP, gaming, remote desktop, telnet, and more
Specifications: | © 2026 Respective owners and brand holders. This table has been carefully researched and generated by ComXpert International CC (//www.comx-computers.co.za), however, errors and omissions may occur. Only references to South Africa apply. All products are sourced in South Africa from the official suppliers and the warranty is that of the local supplier. E&OE. This table and our site's content may be used on condition that this notice and link remains intact and unaltered. | Specifications for the product series | | Product Code | TDM-C504 | | Hardware | | Standards | Compliant with ADSL standards | | - ANSI T1.413 Issue2 | | - G.992.1 (G.dmt, Annex A) | | - G.992.2 (G.lite) | | Compliant with ADSL2 standard | | - G.992.3 (G.dmt.bis, Annex L) | | Compliant with ADSL2+ standard | | - G.992.5 Annex A and M | | IEEE 802.3u 10/100Base TX Fast Ethernet | | Protocol | TCP/IP, NAT, HTTP, DHCP Server/Relay/Client, DDNS, DNS Proxy, UPNP, RIP (v1 and v2) | | Firewall | Network Address Translation (NAT) | | Stateful Packet Inspection (SPI) | | Packet Filtering – IP, MAC, Domain | | Management Access Control for LAN | | ATM | VC and LLC Multiplexing | | Bridged/Routed Ethernet over ATM (RFC1483/2684) | | OAM F4/F5 loop-back | | ATM AAL5 adaptation | | PPP over ATM (RFC2364) | | PPP over Ethernet (RFC2516) | | ATM Traffic Shaping QoS(UBR, CBR, rt-VBR, nrt-VBR) | | Management | Web based Configuration (HTTP) | | Command Line Interface (CLI) via Telnet | | SNMP v2c | | IGMP v1 and v2 | | SW upgrade | | ATM PVC Remote Management | | WAN Port (ADSL line Interface) | 1 x RJ-11 port | | LAN Port | 4 x 10/100Mbps Auto-MDIX RJ-45 port | | Reset Button | Reset to factory default | | On/Off Power Button | Power on/off button | | LED | Power, LAN: Link/ACT, ADSL, Internet | | Power | A: 9V DC 1A external power adapter | | EU : 12V AC 0.5A external power adapter | | Power Consumption | 5 watts | | Dimensions | 145 x 113 x 28mm (5.7 x 4.4 x 1.1 in) | | Weight | 280 g (9.9 oz) | | Temperature | Operating: 5° ~ 45° C (41° ~ 113° F), Storage: -20° ~ 60° C (-4° ~ 140° F) | | Humidity | Max. 90% (non-condensation) | | Certifications | CE, FCC |
Similar Network Routers (wired broadband routers)
The best price and guaranteed service and backup from official computer suppliers in South Africa for the TDM-C504 Trendnet ADSL Fast Ethernet/USB Combo Modem/Router. Available from this online computer store delivering door-to-door in Johannesburg, Cape Town, Port Elizabeth, Pretoria, Pietermaritzburg, Polokwane, Durban and all over South Africa. Find related TDM-C504 Trendnet ADSL Fast Ethernet/USB Combo Modem/Router products in our Network Routers (wired broadband routers) Category for even more options. Read reviews and find out about TDM-C504 Trendnet ADSL Fast Ethernet/USB Combo Modem/Router. Discounts, specials and cheap prices only at ComX Computers.
| |